valse’s weblog

“L’uomo è il computer più straordinario di tutti.”





Finalmente Alfa 147!

Inviato da valse il 5 February 2007

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /membri/valse/wp-includes/functions-formatting.php on line 76

Sono particolarmente felice in questo periodo… nonostante tutto non sia perfetto ma le cose sembrano prendere la strada giusta.

Il 24 gennaio 2007 indica per me l’inizio di una nuova avventura dopo il grande successo della prima automobile che ho acquistato (grande Clio!)… alle 19 e qualcosa esco dal concessionario e comincio a percorrere i primi chilometri con la mia nuova Alfa 147 1.9 JTDm 120CV Collezione!

Veramente un’emozione unica… un nuovo mondo!

Modellazione tazza in 3ds max e render VRay.

Inviato da valse il 2 October 2006

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /membri/valse/wp-includes/functions-formatting.php on line 76

Finalmente ho deciso di dedicarmi alla cg (computer graphics) e per iniziare ho voluto seguire questo videotutorial dell’utente ciberdany sul forum di treddy.com.

Il tutto è stato creato con 3ds max con il render VRay; il mio risultato è stato questo:

tazza

Impostare “register_globals off” su host php cgi

Inviato da valse il 14 September 2006

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /membri/valse/wp-includes/functions-formatting.php on line 76

Mi sono finalmente imbattuto nella mia prima installazione del famoso cms Joomla 1.0.11…

…tutto inizia alla meraviglia… mio stupisco anche del setup veramente ottimo… entro come amministratore ed ecco comparire due warnings (necessari per la sicurezza): il primo riguarda un settaggio in file di configurazione e il secondo invece mi dice di impostare “register_globals” su off. Questo parametro è contenuto nel file php.ini e dato che il server non è mio e neanche voglio chiamare i responsabili in quanto sarebbe inutile, parto alla ricerca di una possibile soluzione.

Ecco la prima: inserire nel file “.htaccess” la riga “php_value register_globals off”; faccio un bel refresh ed ecco che inizia il dramma! Internal server error e non va più nulla… dal log del monitoraggio del sito vedo che il comando “php_value” non è valido… e perché?! Sfortuna vuole che l’host usa php in modalità cgi che non permette comandi simili…

Che fare?! Trovo una discussione di un problema simile in cui consigliava di inserire un file “php.ini” nella root del server con all’interno “register_globals = 0″; provo anche io ma nada… non funziona… però mi accorgo che con il phpinfo() la fatidica impostazione si è impostata su off :-|

Mi viene un dubbio… e se l’impostazione personalizzata riguarada solo la cartella in cui ho messo il file php.ini?! Provo a spostarla nella cartella “administrator” dell’installazione di Joomla et voilà… il warning scompare e “register_globals” è off!

Ho fatto anche alcuni test sull’host in questione… inoltre ne stiamo discutendo anche sul forum di joomla.it in questo thread.



Warning: strpos() expects parameter 1 to be string, array given in /membri/valse/wp-includes/functions.php on line 217